今天尝试使用了一下 lute-http 使用的是 docker 部署方式、部署成功后 solo 检测到了 lute-http,但是,却有很多报错信息、一直提示连接被拒绝、使用的时候也发现不了什么问题、想请教一下这是什么问题?怎么解决。 [图片] [图片]

lute-http 的使用问题

今天尝试使用了一下 lute-http 使用的是 docker 部署方式、部署成功后 solo 检测到了 lute-http,但是,却有很多报错信息、一直提示连接被拒绝、使用的时候也发现不了什么问题、想请教一下这是什么问题?怎么解决。

image.png

image.png

  • Solo

    Solo 是一款小而美的开源博客系统,专为程序员设计。

    Solo 有着非常活跃的社区,可将文章作为帖子推送到社区,来自社区的回帖将作为博客评论进行联动。

    这是一种全新的网络社区体验,让热爱记录和分享的你不再感到孤单!
    具体细节请浏览 B3log 构思

    905 引用 • 6909 回帖 • 666 关注
  • Lute

    Lute 是一款结构化的 Markdown 引擎,支持 Go 和 JavaScript。

    5 引用 • 94 回帖 • 5 关注
  • Q&A

    提问之前请先看《提问的智慧》,好的问题比好的答案更有价值。

    1354 引用 • 8860 回帖 • 575 关注
24 回帖
请输入回帖内容...
  • 88250

    Lute HTTP 的容器有报错么?

    1 回复
  • expoli

    没有的

    image.png

  • 88250

    可能是两个容器之间网络不通造成的。

    1 回复
  • expoli

    是吗?那我等一下试试、但是 solo 显示已经获取到 lute-http 已经启用了、所以就感觉比较奇怪 😄

    1 回复
  • 88250 1

    Available 的日志有点描述不准确,实际上是添加了参数就 true 了 🤣

    3 回复
  • expoli

    啊哈哈哈哈 可以可以huaji

  • expoli

    老哥谢啦 😎

  • expoli

    看着是通的哈、是在 一个网络里面的

    image.png

    image.png

    1 回复
  • 88250

    麻烦看下 lute-http 的端口绑定是不是不大对劲,代码里写死了只绑 127.0.0.1:8249

    1 回复
  • expoli

    强烈建议 把监听地址换成 0.0.0.0 啊、要不然没得办法啊、连不上 😭 哭了都

    1 回复
  • 88250

    好的,之前主要是担心安全问题,不过用 Docker 都跑虚拟网络不发布端口也没这问题了。估计过 30 分钟后新的镜像就可以构建好了,再帮忙试试看,谢谢!

    1 回复
  • expoli

    好的 辛苦您啦huaji

    1 回复
  • 88250

    新的 Lute HTTP 镜像构建好了,拉取重启试试。

    1 回复
  • expoli

    这个我就有点搞不明白了,solo 容器里面使用 curl 测试 lute-http,是没有问题的,但是在使用的过程中,依旧是报错误,连接拒绝。😅

    Screenshot20191118071635005com.server.auditor.ssh.client.jpg

    Screenshot20191118071858081com.server.auditor.ssh.client.jpgIMG20191118072129.jpg

    1 回复
  • 88250

    我也没看出问题来 🤣 刚刚改了下 Solo 的报错日志,镜像已经打好请更新。

    2 回复
  • expoli

    hhh 好的,我这边再尝试一下 😆

  • expoli

    找到问题了,solo 默认连接的是 localhost 的 8249,solo 镜像制定的 Lute 地址没生效 😂 原来报错日志没打出来,现在能看到了。但是我感觉我的地址制定貌似是没有问题的。

    Screenshot20191118102901073com.server.auditor.ssh.client.jpg

    Screenshot20191118102702250com.server.auditor.ssh.client.jpg

    1 回复
  • 88250

    谢谢帮忙诊断问题,已经修复,请更新。

    1 回复
  • expoli

    目前已经正常了,谢谢老哥,辛苦啦 😋

    1 回复
  • 88250

    客气,感谢帮助。

  • zhoujin7

    等下试试 之前搞了半天也是这个错误

  • Adrift001

    我曹?这么吊的?都用手机操作了?

  • Adrift001

    @expoli 这是什么工具呢?

  • zhoujin7

    感谢 ~ 成功了 ~

请输入回帖内容 ...