最近计划将学习 Solo,可是在搭建开发环境时遇见了问题;简单说下问题出现的场景和我操作的步骤: 1、从码云网站下载 Solo 项目代码,版本是 Solo 3.6.0; 2、使用 Eclipse 的 Maven(Maven 版本 3.6.1)插件将项目导入工作空间; 3、导入后展开项目结构,发现: a、JDK 版本是 ..

关于 Solo 开发环境中大量错误的求教

最近计划将学习 Solo,可是在搭建开发环境时遇见了问题;简单说下问题出现的场景和我操作的步骤:
1、从码云网站下载 Solo 项目代码,版本是 Solo 3.6.0;
2、使用 Eclipse 的 Maven(Maven 版本 3.6.1)插件将项目导入工作空间;
3、导入后展开项目结构,发现:
a、JDK 版本是 J2SE1.4;
b、代码中存在大量的红色错误提示;
这肯定是我哪里需要取配置,或者其他原因,但是我找不到原因,没办法解决。我就是想能后整个项目没有错误提示,然后可以正常的以开发模式运行起来。希望高手给与指点,万分感激。
如图:
image.png

  • Solo

    Solo 是一款小而美的开源博客系统,专为程序员设计。

    Solo 有着非常活跃的社区,可将文章作为帖子推送到社区,来自社区的回帖将作为博客评论进行联动。

    这是一种全新的网络社区体验,让热爱记录和分享的你不再感到孤单!
    具体细节请浏览 B3log 构思

    723 引用 • 5462 回帖 • 695 关注
  • Q&A

    提问之前请先看《提问的智慧》精读注解版,好的问题比好的答案更有价值。

    1123 引用 • 7350 回帖 • 586 关注
3 回帖   
请输入回帖内容...
  • 88250

    这可能是你 IDE 配置的问题,不是代码导致。我不使用 eclipse 很多年了,这方面帮不上你。如果方便,你可以用 IntelliJ IDEA 或者 NetBeans IDE 来打开 Solo 项目,应该就不会有任何报错了。

    1 回复
  • githudk        

    好的,我换个工具尝试下吧,谢谢!

  • githudk  

    问题已经解决,原因是我用的 MyEclipse 不支持 JDK1.8,而 Solo3.6.0 需要 JDK1.8 或更高版本的。通过下载并使用 Eclipse2019 版本,支持了 JDK1.8 后,问题消失。