"我按照 [链接] 和 [链接] 的步骤部署好了 solo,但发现使用 https 时皮肤不能使用,请问这种情况怎么处理? [图片]"

更换好 HTTPS 后,发现皮肤不能用

我按照 https://hacpai.com/article/1549530952920https://hacpai.com/article/1553755313169 的步骤部署好了 solo,但发现使用 https 时皮肤不能使用,请问这种情况怎么处理?

QQ20190329-163118

  • Solo

    Solo 是一款小而美的开源博客系统,专为程序员设计。

    Solo 有着非常活跃的社区,可将文章作为帖子推送到社区,来自社区的回帖将作为博客评论进行联动。

    这是一种全新的网络社区体验,让热爱记录和分享的你不再感到孤单!
    具体细节请浏览 B3log 构思

    652 引用 • 4972 回帖 • 710 关注
  • Q&A

    提问之前请先看一下这篇文章 《提问的智慧》精读注解版,好的问题比好的答案更有价值。

    1040 引用 • 6631 回帖 • 595 关注
被采纳的回答
  • 88250    

    启动时带参 --server_scheme=https 或修改 latke.props 中的 serverScheme=https

9 回帖   
请输入回帖内容...
  • 88250

    启动时带参 --server_scheme=https 或修改 latke.props 中的 serverScheme=https

    1 回复
  • MisterBooo        

    还是无效。。。。

    #### Server ####
    # Browser visit protocol
    serverScheme=https
    serverHost=cxyxiaowu.com
    serverPort=
    #### Cookie ####
    cookieName=solo
    cookieSecret=Beyond
    
  • 88250

    改完需要重启哦

    1 回复
  • MisterBooo        

    原来 tomcat 也要重启,历经半个月总算部署成功了😂

    1 回复
  • 88250      

    建议用 Docker 进行部署,这样可以实现自动升级。

    1 回复
  • MisterBooo        

    我发现没有适合小白的 Docker 部署文档,我前两天按照 https://bbs.halo.run/d/9-docker-compose-halo 部署好了 halo 这个博客,但我搜了几天论坛里的 Docker 部署都是失败的😂

    1 回复
  • 88250      

    可以参考一下最新的 README 搭建有问题随时联系 😅

    1 回复
  • MisterBooo        

    大佬,还是想请教一个问题。我下载上传了 amaze 这个皮肤,我上传到了 skins 里面,在偏好里面可以看到,但是选择它的时候会出现 500 的错误。
    Failed to load resource: the server responded with a status of 500 ()

    1 回复
  • 88250      

    可能是因为最近版本更新有点多,这款皮肤不兼容,如果方便的话麻烦把报错日志通过 issue 发给皮肤作者进行反馈。

请输入回帖内容 ...