"我之前用的是老版本,这次看到 3.2 出来了,就直接 git 下来了,结果启动的时候老是让我先升级到 3.0.0 。 各位大佬要怎么解决????"

SOLO 启动提示请先升级到 3.0.0

我之前用的是老版本,这次看到 3.2 出来了,就直接 git 下来了,结果启动的时候老是让我先升级到 3.0.0 。
各位大佬要怎么解决????

感谢    关注    收藏    赞同    反对    举报    分享
9 回帖    
请输入回帖内容...
  • 88250      

    • v3 之前只能一个一个版本升级
    • v3 之后支持跨版本升级

    所以如果要升级的话只能一个版本一个版本先升到 v3.0.0,然后再部署最新版即可。期间请参考每个版本的发布说明,里面有必要的迁移步骤。

    如果你仅在乎文章数据,不是太在乎非文章数据(比如评论、自定义页面、各种参数配置)的话,可以使用导出功能导出 md 文件,然后把老版本清空,重新部署最新版,参考这里进行文章数据导入。

    不想折腾的话就维持原样吧 😅

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • yang17762622            

    我没有在原来的代码上进行升级,是直接一个空仓库拉的最新版

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • 88250            

    那把之前的数据删除一下吧,在 ~/solo_h2 下。昨天刚刚发布 v3.3.0,默认使用 MySQL,从源码构建请看这里

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • yang17762622            

    一个个版本的更新上来了,现在七牛是不用了吗?

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • 88250 1 感谢              

    是的,七牛云支持在之前的版本移除了,现在是内置了社区提供的图床,开箱即用。

    2 回复 
    感谢    赞同    反对    举报    分享       回复
  • yang17762622            

    感谢 DDDD

    感谢    赞同    反对    举报    分享       回复
  • yang17762622            

    发布到云服务上以后,有些访问是 localhost:8080,但是代码中并没有看到在哪改

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • 88250            

    你用了 NGINX 反代么?

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • yang17762622            

    解决了,3.3.0 版本 latke.properties 中没有serverHostserverPort这两个选项,我给加上域名就 OK 了

    感谢    赞同    反对    举报    分享       回复
请输入回帖内容...