Centos7 重启后 SOLO 启动失败
第一次部署能成功,也忘记了具体怎么部署的,今天服务器重启后,SOLO 就启动不起来了
ppl813png
阿里云的域名是www.aixx23.com
nginx 的 log 日志如下:

2018/11/09 21:57:39 [notice] 2130#0: signal process started
2018/11/09 22:06:44 [notice] 2253#0: signal process started
2018/11/09 22:14:13 [error] 2136#0: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "www.aixx123.com"
2018/11/09 22:14:13 [error] 2136#0: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "www.aixx123.com"
2018/11/09 22:14:13 [error] 2136#0: *1 no live upstreams while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET /favicon.ico HTTP/1.1", upstream: "http://backend/favicon.ico", host: "www.aixx123.com", referrer: "http://www.aixx123.com/"
2018/11/09 22:14:18 [error] 2136#0: *1 no live upstreams while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET / HTTP/1.1", upstream: "http://backend/", host: "www.aixx123.com"
2018/11/09 22:14:18 [error] 2136#0: *1 no live upstreams while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET /favicon.ico HTTP/1.1", upstream: "http://backend/favicon.ico", host: "www.aixx123.com", referrer: "http://www.aixx123.com/"
[root@pplsunny  logs]# 

latke.properties 配置文件如下:

#### Server ####
# Browser visit protocol
serverScheme=http
# Browser visit domain name
serverHost=www.aixx123.com
# Browser visit port, 80 as usual, THIS IS NOT SERVER LISTEN PORT!
serverPort=80

#### Cookie ####
cookieName=solo
cookieSecret=Beyond

#### Runtime Mode ####
#runtimeMode=DEVELOPMENT
runtimeMode=PRODUCTION

nginx 的配置如下:

    upstream backend {
      server localhost:8080;
    }

    server {
        listen       80;
        server_name  www.aixx123.com;

        #charset koi8-r;

        #access_log  logs/host.access.log  main;

        location / {
            proxy_pass http://backend$request_uri;
            proxy_set_header  Host $host:$server_port;
            proxy_set_header  X-Real-IP  $remote_addr;
            client_max_body_size  10m;
        }

    }

有遇到这种问题的吗?求大神帮忙看一下。

感谢    关注    收藏    赞同    反对    举报    分享