"Centos7 重启后 SOLO 启动失败 第一次部署能成功,也忘记了具体怎么部署的,今天服务器重启后,SOLO 就启动不起来了 [图片] 阿里云的域名是 www.aixx23.com nginx 的 log 日志如下: 2018/11/09 21:57:39 [notice] 2130#0: signal proce .."

Centos7 重启后 SOLO 启动失败

Centos7 重启后 SOLO 启动失败 第一次部署能成功,也忘记了具体怎么部署的,今天服务器重启后,SOLO 就启动不起来了 ppl813png 阿里云的域名是 www.aixx23.com nginx 的 log 日志如下:

2018/11/09 21:57:39 [notice] 2130#0: signal process started
2018/11/09 22:06:44 [notice] 2253#0: signal process started
2018/11/09 22:14:13 [error] 2136#0: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "www.aixx123.com"
2018/11/09 22:14:13 [error] 2136#0: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "www.aixx123.com"
2018/11/09 22:14:13 [error] 2136#0: *1 no live upstreams while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET /favicon.ico HTTP/1.1", upstream: "http://backend/favicon.ico", host: "www.aixx123.com", referrer: "http://www.aixx123.com/"
2018/11/09 22:14:18 [error] 2136#0: *1 no live upstreams while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET / HTTP/1.1", upstream: "http://backend/", host: "www.aixx123.com"
2018/11/09 22:14:18 [error] 2136#0: *1 no live upstreams while connecting to upstream, client: 60.216.222.56, server: www.aixx123.com, request: "GET /favicon.ico HTTP/1.1", upstream: "http://backend/favicon.ico", host: "www.aixx123.com", referrer: "http://www.aixx123.com/"
[root@pplsunny  logs]# 

latke.properties 配置文件如下:

#### Server ####
# Browser visit protocol
serverScheme=http
# Browser visit domain name
serverHost=www.aixx123.com
# Browser visit port, 80 as usual, THIS IS NOT SERVER LISTEN PORT!
serverPort=80

#### Cookie ####
cookieName=solo
cookieSecret=Beyond

#### Runtime Mode ####
#runtimeMode=DEVELOPMENT
runtimeMode=PRODUCTION

nginx 的配置如下:

    upstream backend {
      server localhost:8080;
    }

    server {
        listen       80;
        server_name  www.aixx123.com;

        #charset koi8-r;

        #access_log  logs/host.access.log  main;

        location / {
            proxy_pass http://backend$request_uri;
            proxy_set_header  Host $host:$server_port;
            proxy_set_header  X-Real-IP  $remote_addr;
            client_max_body_size  10m;
        }

    }

有遇到这种问题的吗?求大神帮忙看一下。

感谢    关注    收藏    赞同    反对    举报    分享
6 回帖    
请输入回帖内容...
  • pplsunny      

    @88250 D 大能帮忙指点一下吗?

    感谢    赞同    反对    举报    分享       评论    回复
  • 88250      

    看容器日志。

    1 回复 
    感谢    赞同    反对    举报    分享       评论    回复
  • pplsunny            

    日志看不出什么原因,D 大你觉得一般是什么原因造成的

    1 回复 
    感谢    赞同    反对    举报    分享       评论    回复
  • 88250            

    进程没启动。

    感谢    赞同    反对    举报    分享       评论    回复
  • moonce      

    你是用得什么启动得?tomcat 么? 还有你应该是 8080 端口得那个容器没启动,nginx 都连接不过去。。

    1 回复 
    感谢    赞同    反对    举报    分享       评论    回复
  • pplsunny            

    解决了,是 solo 的启动方式不正确

    感谢    赞同    反对    举报    分享       评论    回复
请输入回帖内容...