"C:\Users\Administrator\Desktop\solo>java -cp 'WEB-INF/lib/*;WEB-INF/classes' org .b3log.solo.Starter [INFO ]-[2018-11-01 17:59:14]-[com.zaxxer.hikari.HikariD .."

solo2.9 启动报错

C:\Users\Administrator\Desktop\solo>java -cp "WEB-INF/lib/*;WEB-INF/classes" org
.b3log.solo.Starter
[INFO ]-[2018-11-01 17:59:14]-[com.zaxxer.hikari.HikariDataSource:110]: HikariPo
ol-1 - Starting...
[INFO ]-[2018-11-01 17:59:14]-[com.zaxxer.hikari.HikariDataSource:123]: HikariPo
ol-1 - Start completed.
[ERROR]-[2018-11-01 17:59:14]-[org.b3log.solo.service.UpgradeService:165]: Attem
pt to skip more than one version to upgrade. Expected: 2.9.4, Actually: 2.5.0

@88250 帮忙看下,我是直接百度云下载的 war 包

感谢    关注    收藏    赞同    反对    举报    分享
被采纳的回答
  • 88250  

    那估计是之前的老数据还在,你看下用户目录(user home)下面,删了 solo_h2 重启就行。

4 回帖    
请输入回帖内容...
  • 88250      

    不能跨版本升级,只能一个版本一个版本升。

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • xuwangcheng14            

    我没升级啊,直接下的 2.9 啊。百度下载的。

    1 回复 
    感谢    赞同    反对    举报    分享       回复
  • 88250            

    那估计是之前的老数据还在,你看下用户目录(user home)下面,删了 solo_h2 重启就行。

    感谢    赞同    反对    举报    分享       回复
  • xuwangcheng14      

    谢谢了,的确。

    感谢    赞同    反对    举报    分享       回复